These instructions describe how to load OpenMRS into Eclipse version 3.4.2 using the Maven Eclipse Plugin. Eclipse and Maven are assumed to be installed previously.

Contents

Setup Eclipse Workspace for Maven

Run the follow command from the command line at the root of the checked out project:
mvn eclipse:configure-workspace -Declipse.workspace=<path-to-eclipse-workspace>

Start Eclipse using the Configured Workspace

On starting Eclipse, select the <path-to-eclipse-workspace> used in the previous step.
If Eclipse is already started, switch the workspace by File -> Switch Workspace -> Other... and select the workspace path.

Setup Maven commands in Eclipse

Maven commands can be setup in Eclipse as External Tools by Run -> External Tools -> External Tools Configurations... -> Program -> New.

The Maven executable path should be entered as the Location either as the full path or as a variable.
To create the variable, select Variables... -> Edit Variables... -> New...
Enter a name with the value being the path to the Maven executable bin/mvn

Select the newly created variable name for the Location, and enter the path to the checked out OpenMRS project as the Working Directory.
Enter the Arguments for the eclipse command:
eclipse:eclipse --batch-mode -DdownloadSources=true

Refresh the workspace after running the commands by selecting the Refresh tab and 'Refresh resources upon completion'

Apply the External Tools changes and Run. Output from the command with appear in the Console.
After running, the Maven tools are available in the External Tools dropdown.

Follow the same steps for adding other Maven commands.
For the build command, enter these the Arguments:
clean install --batch-mode

Generate Eclipse Projects

Generate the Eclipse .project, .classpath, and .settings files by running the eclipse command using the External Tools in Eclipse or through the command line.

If using External Tools, follow the steps above if not already complete to create the Maven Eclipse command configuration and Run.

If using the command line run:
mvn eclipse:eclipse -DdownloadSources=true
If running from the command line, manually update the projects in Eclipse by selecting them all, right-clicking, and selecting Refresh.

Each time the dependencies are changed in the pom.xml, re-run this command to update the libraries in Eclipse.

Import Projects in Eclipse

Import the generated Eclipse projects by File -> Import... -> General -> Existing Projects.

Browse to the location of the checked out OpenMRS project and select the three OpenMRS projects (api, web, webapp)

Update Eclipse View

A suggestion is to use the Java perspective with the Referenced Libraries node.
Change the perspective by Window -> Open Perspective -> Java

Set the Referenced Libraries node by selecting Show 'Referenced Libraries' Node