Wiki Spaces

Documentation
Projects
Resources

Get Help from Others

Q&A: Ask OpenMRS
Discussion: OpenMRS Talk
Real-Time: IRC Chat | Slack

Documentation

Page tree
Skip to end of metadata
Go to start of metadata

We don't yet actively recommend this upgrade and this page in still a work in progress so be sure to come back and check it

 

At the end of the year, we will release a new version of the OpenMRS platform that requires Java 8, this implies that the next release of the reference application too will require java 8.

You can download the latest version of java from the oracle website.

Things you might to pay attention to:

  •  The VM options PermSize and MaxPermSize were removed, this technically implies that the application is only limited by the amount of available native memory, Use the new flag MaxMetaspaceSize to limit the amount of native memory used by the application. It is analogous to MaxPermSize.
  • Remember to create a back up of your system especially on MACs, when installing java 8, it overwrites your existing java installation and apparently oracle no longer provides downloads for java 6. If you wish to fall back or to have multiple JREs apple provides java 6 downloads here.
  • No labels