Have you implemented OpenMRS? Please participate in the Implementation Site Survey. If you already have, thank you!
Page tree
Skip to end of metadata
Go to start of metadata

The scripts on this page require the bash shell. They also do not work with the BSD version of sed that comes with Mac OSX. Please install the GNU sed instead which is available through brew.

Converting your Module

There are two scripts for converting an existing module. Choose only one and run it.

These scripts should be executed in the project directory using bash:

bash mavenize-module-11_openmrs1.8.sh

Update the SH_OPENMRS_VERSION variable at the beginning of the script to a version of OpenMRS available in the Nexus Maven repository.
The OpenMRS version for the module can also be set by changing the openMRSVersion property in the pom.xml after running the script.

For libraries in the lib folder, replace the commented dependency sections in the pom.xml files with the correct dependencies. Search for the dependency information in the Maven central repository, for example groovy-all 1.7.5 and commons-codec 1.4

See TRUNK-1686 for more background info

Converting Trunk or a Branch

It is uncommon to need this file. This should only be run against checkouts of TRUNK or a branch off of trunk

Download this script: mavenize.4.sh

Run it at command line with:

bash mavenize.4.sh

See TRUNK-241 for more information

Convert a Patch File

Download this sed script: mavenize-a-patch-v1.sed

Run it with this link at command line:

sed -f mavenize-a-patch-v1.sed old-trunk-patch.patch > old-trunk-patch-mavenized.patch

See TRUNK-1692 for more background info on this